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Introduction
Dolphin Power Tools Overview
Note: Screen captures/icons in this user’s guide may differ from what appears on your device.

Dolphin Power Tools are installed in every Dolphin terminal. Different versions of Power Tools apply to different Dolphin termi-
nals depending on the terminal’s model or operating system.

Software Requirements

Dolphin Terminals
Dolphin Power Tools are designed to work with Dolphin devices powered by Android.

Desktop
The Power Tools installer and the workstation version of EZConfig Editor are designed to work with the following operating
systems:

• Microsoft® Windows® XP

• Microsoft® Windows® 2000

• Microsoft® Windows® NT

• Microsoft® Windows® Vista

• Microsoft® Windows® 7

• Microsoft® .NET Framework 2.0

Power Tools Main Window

Tap the Launcher > Power Tools . The Power Tools main screen opens.

Icon Description Page

Enables or disables applications and stops application updates. 10-2

Backs up and restores user settings and data files. 7-1

Programs the LEDs on the top panel to monitor battery power. 10-2

o

Runs the selected applications automatically after rebooting. 6-1
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Configure Hotkeys activates button assignments in the Buttons setting. 10-3

Connection Manager switches between WiFi and cellular carriers. 8-1

Counter Viewer displays counter information for key presses and charging. 10-4

EZConfig opens a window to scan EZConfig bar codes. 5-1

EZConfig Editor allows you to view and edit XML configuration files on the terminal. 3-1

EZConfig Utils creates a backup copy of the default XML configuration files. Al-
lows the user to view and edit these files.

3-4

File Browser displays files and folders on the device. 10-4

IPConfig displays, releases and renews IP parameters. 8-6

Logging configures logging options for system events and system status.
Note: This feature is only available on the Dolphin 7800.

10-12

LogView displays a log of system information. 10-16

NoSIP disables the Software Input Panel (SIP). 10-18

Ping displays an interface for the ping echo request utility. 8-7

Icon Description Page
1 - 2



Exiting the Power Tools Main Window

Press Back or Home on the keyboard.

Storage Locations

The \Honeywell folder on the Dolphin terminal’s SD card is semi-permanent storage on the terminal. By default, files in this
folder are maintained after a reboot. However, there is an option (Settings > Storage > Erase SD card) that clears the con-
tents of the SD card.

Reboot performs a reboot from the touch screen, as opposed to the keyboard com-
mands.

10-18

Route displays and allows editing of the rules for packet destination across the
subnets.

8-8

ScanTool scans a bar code and displays or shares the results. 9-4

ScanWedge enables the Dolphin terminal to interpret data received via the decod-
er interface as keystrokes.

9-1

Shell Plus provides a Linux shell window. 10-18

Suspend manually puts the terminal into Suspend mode from the touch screen, as
opposed to the keyboard commands or time-out settings.

10-19

SysInfo displays system information. 10-19

Task Manager lists all running processes and allows you to end selected process-
es.

10-22

Wi-Fi Radio Settings configures channels, roaming, data rates and other 802.11
settings.

8-2

Wireless Manager enables and disables Wi-Fi, selects Access Points and tracks
roaming statistics.

8-3

Icon Description Page
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Upgrading Power Tools

Upgrades for the Power Tools and other system software on the Dolphin come in the form of zip files. Place these zip files in the
\Honeywell\autoinstall folder on the Dolphin terminal’s SD card for automatic installation after a reboot (AutoInstall
must be enabled.). Upgrades are available from Customer Support (see page 11-1) or www.honeywellaidc.com.

Note: To copy the Power Tools upgrade files, an active USB connected session must be initiated between a host workstation
and the Dolphin terminal. USB storage must also be enabled on the Dolphin terminal.
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EZConfig Utilities
Overview
EZConfig is a set of utilities consisting of the EZConfig Editor, the EZConfig Client and a series of XML files.

Examples are provided at the end of this section for configuring the Dolphin device:

• Configuring Device Using EZConfig Bar Codes on page 2-1
• Configuring Device without EZConfig Bar Codes on page 2-3

EZConfig Editor
Edits and creates configuration files in the XML file format for Dolphin terminals. There are two versions of EZConfig Editor: one
for the terminal and one for the workstation.

Workstation EZConfig Editor
For details about the workstation editor, see EZConfig Editor on the PC (Workstation) beginning on page 4-1.

The workstation EZConfig editor can:.

• Create and modify XML files–Working with Open XML Files (see page 4-4).
• Generate bar codes from XML files–Creating Bar Codes (see page 4-10).

Terminal EZConfig Editor
For details about the terminal editor, see EZConfig Editor on the Dolphin Terminal beginning on page 3-1.

The terminal EZConfig editor can:

• Modify XML files–Editing XML Files (see page 3-3).

EZConfig Client
Decodes the bar codes generated by EZConfig Editor on the workstation. For details, see EZConfig Client beginning on page
5-1.

Configuring Device Using EZConfig Bar Codes
This section contains an example of how to set up Wi-Fi on a Dolphin terminal using EZConfig bar codes. For more information
on EZConfig bar codes, see Creating Bar Codes on page 4-10.

Assumptions:

• The Dolphin terminal should be upgraded to the latest software load before beginning the process. See Upgrading Power
Tools on page 1-4.

• EZConfig is installed on a workstation.

Create Bar Codes
1. Connect the Dolphin terminal via USB to the workstation and enable USB storage.

2. Open Power Tools > EZConfig Utils.

3. Tap DeviceConfig to open DeviceConfig.xml.

4. Changes can be made to the DeviceConfig.xml file, but is not necessary to do so at this time.

5. Press the MENU key and tap Save.

6. On the workstation, locate the drive corresponding to the Dolphin terminal’s SD card.

7. Browse to the \Honeywell\ezconfig\generated folder.

8. Copy the DeviceConfig.xml file from the location above to the workstation PC.

9. Open EZConfig (see Opening EZConfig Editor on the Workstation on page 4-1) on the workstation PC.
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10. Drag the DeviceConfig.xml file into the EZConfig editor.

11. If a message is displayed that the file was created with an older tool, click OK to continue.

12. If necessary, expand the branches to view the Wi-Fi configuration items.

13. Locate Profile 1 and complete the entires necessary for your Wi-Fi configuration (e.g., SSID) and any encryption/
security entries necessary for connection to the Wi-Fi network. Any items that show a blank Value field use the default
value.

14. Additional advanced Wi-Fi configuration items are located under the tiwlan.ini branch.

15. When finished, tap the bar code icon in the menu bar.

16. Make sure to check Full Contents rather than Simplified under Options.

17. Click Print to print the bar codes. The default scale factor is 2. A lower number increases bar code size and a larger
number decreases bar code size.

Scan Configuration Bar Codes
For more information on scanning configuration bar codes see Using EZConfig Client on page 5-1.

1. Open Power Tools > EZConfig on the Dolphin terminal.

2. Aim the scanner at the first configuration bar code and tap Scan. Upon a successful scan, the display is updated to
reflect the total number of configuration bar codes in the set and which one(s) have been scanned.

3. Repeat the scan procedure for each bar code in the set.

4. After the last bar code has been scanned, the display reads “Decode success, try to configure”.

5. If the proper Wi-Fi parameters were entered, the Dolphin terminal connects to the network. The connection can be
verified by looking for the Wi-Fi connected icon in the status indicators area at the upper right area of the screen or
selecting Settings > Wireless & networks to view network status.
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6. The configuration parameters read from the bar code are stored in the \confige.xml and
\honeywell\deviceconfig\DeviceConfig.xml files.

Configuring Device without EZConfig Bar Codes
For more information

1. Open Power Tools > EZConfig Utils on the Dolphin terminal.

2. Select the DeviceConfig file.

3. Locate Profile 1 and complete the entires necessary for your Wi-Fi configuration such as the SSID and any encryption/
security items necessary for connection to the Wi-Fi network. Any items that show a blank Value field use the default value.

4. Additional advanced Wi-Fi configuration items are located under the tiwlan.ini branch.

5. Press the MENU key and tap Save.

6. Press the MENU key and tap Update Configure to apply the saved changes to the terminal.

7. A message is displayed indicating the device must be rebooted before the changes take effect.

Reboot the device.
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EZConfig Editor on the Dolphin Terminal
Overview
EZConfig Editor edits and manages XML files for Dolphin terminals. There are two versions of EZConfig Editor: one for the Dol-
phin terminal and one for the workstation. In the workstation editor, EXM files are edited, saved, then transferred to the Dolphin
terminal. In the terminal editor, XML files are edited and saved right on the terminal

This chapter details EZConfig Editor running on a Dolphin terminal. Refer to EZConfig Editor on the PC (Workstation) beginning
on page 4-1 for information about using EZConfig Editor on a workstation.

Accessing EZConfig Editor

1. Tap Launcher > Power Tools > EZConfig Editor

2. Tap Open XML and browse to the location of the device config XML files.  

XML File Description Location

confige Configuration settings from the last EZConfig bar code scanned. /config

DeviceConfig General device settings including connection settings, device set-
tings, feedback, sound, etc.

/sdcard/Honeywell/ezconfig/gen-
erated

XML File Description Location

appsconfig Configuration settings for the AppsConfig Power Tool. See Apps
Config for details.

/sdcard/Honeywell/ezconfig

autorun Configuration settings for the AutoRun Power Tool. See Configure
Autorun for details.

/sdcard/Honeywell/ezconfig

battmon Configuration settings for the BattMon Power Tool. See BattMon
for details.

/sdcard/Honeywell/ezconfig

bootstrap Configuration settings for Remote MasterMind. See Remote
MasterMind© for details.

/sdcard/Honeywell/ezconfig

btprintdemo Configuration settings for the BTPrintDemo. /sdcard/Honeywell/ezconfig

camera Configuration settings for the CameraDemo. /sdcard/Honeywell/ezconfig

connectionmanager Configuration settings for the ConnectionManager Power Tool.
See Connection Manager for details.

/sdcard/Honeywell/ezconfig

hotkeys Configuration settings for the Hotkeys Power Tool. See Configure
Hotkeys for details.

/sdcard/Honeywell/ezconfig

imagedemo Configuration settings for the Camera Demo. /sdcard/Honeywell/ezconfig

ipconfig Configuration settings for the IPConfig Power Tool. See IP Config
for details.

/sdcard/Honeywell/ezconfig

iqdemo Configuration settings for the IQImageDemo. /sdcard/Honeywell/ezconfig

logging Configuration settings for the Logging Power Tool. (Only available
on the Dolphin 70e terminal.) See Logging for details.

/sdcard/Honeywell/ezconfig

logview Configuration settings for the LogView Power Tool. See Log
Viewer for details.

/sdcard/Honeywell/ezconfig
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XML File Directories
The directories below are located on the SD card.

\
This is the root directory of the SD card. If a configuration bar code has been scanned with the device, confige.xml is
stored here. The contents of the confige.xml file depend on the type of configuration bar code that was scanned. For
example, if the configuration bar code was created from a deviceconfig.xml file, the confige.xml file contents would
be the same as a deviceconfig.xml file.

\Honeywell\ezconfig
The xml files at this location contain the default settings. If any modifications are made to the xml files in this directory, the
files are reset to the defaults at the next reboot.

\Honeywell\ezconfig\generated
The xml files in this directory are the customized versions, if any. When the EZConfig Utils Power Tool is used, it edits the
xml files in this directory. When the xml file is saved, it is saved in this directory.

Persistent Settings

\Honeywell\deviceconfig
If a configuration bar codes is created from a deviceconfig.xml file and scanned with the device, a devciecon-
fig.xml file containing the settings from that bar code is stored in this directory. When the device is reset, this
deviceconfig.xml file is used to persist those settings after the reset.

Opening XML Files
Open the EZConfig Editor Power Tool and browse to the XML file location. Tap on the XML file to open.

XML File Structure
Each XML file contains a variety of keys. In general, the keys located at the beginning of the XML file identify the XML file and
keys at the end of the XML file identify the application version. These keys cannot be edited.

Keys that contain configurable parameters are located in the section(s) between the read only keys at the beginning and ending
of the xml file. Keys that can be edited have a white background in the text boxes. Keys that cannot be edited have a gray back-
ground in the text boxes.

ping Configuration settings for the Ping Power Tool. See Ping for de-
tails.

/sdcard/Honeywell/ezconfig

route Configuration settings for the Route Power Tool. See Route for de-
tails.

/sdcard/Honeywell/ezconfig

scandemo Configuration settings for the ScanDemo. /sdcard/Honeywell/ezconfig

scanwedge Configuration settings for the ScanWedge Power Tool. See
ScanWedge for details.

/sdcard/Honeywell/ezconfig

signature Configuration settings for the SignatureDemo. /sdcard/Honeywell/ezconfig

term Configuration settings for the Shell Plus Power Tool. See Shell
Plus for details.

/sdcard/Honeywell/ezconfig

wirelessmanager Configuration settings for the Wireless Manager Power Tool. See
Wireless Manager for details.

/sdcard/Honeywell/ezconfig

XML File Description Location
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Launch Associated App
Press the MENU key and tap Launch Associated App to launch the application associated with the XML file.

Save
Press the MENU key and tap Save to save any changes in the XML file. This option does not apply those changes to the
application at this time.

Update Configure
After saving the XML file, press the MENU key and tap Update Configure to apply the changes to the application. A
reboot may be required for some configuration changes to take effect. In this case, a prompt to reboot the device is dis-
played. Use the Reboot Power Tool or key press sequence to reboot the terminal.

About
Press the MENU key and tap About to display information about the EZConfig Editor Power Tool.

Editing XML Files

Modifying Text
1. Use the + icon to expand the view to the desired key.

.

2. After the desired key is selected, tap inside the [Key], [Value] or [Desc] fields to edit the information. The selected field
is highlighted with an orange box. If a field is shaded in gray, the text in that field cannot be edited.

3. Edit the text.

Sections appear in the top half
of the window.

Keys appear in the bottom half of
the window.
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4. Press the MENU key and tap Save to save changes. You can also press the Back key and be prompted to save the
changes.

5. Tap Yes to save changes or tap No to close the file without changes.

Launching Associated Applications
Press the MENU key and tap Launch Associated App. Launch Associated App is enabled only when there is an appli-
cation associated with the XML file. Selecting this item automatically saves the XML file and launches the associated appli-
cation while the XML file remains open.

EZConfig Utils
The EZConfig Utils Power Tool creates a copy of the XML files on the SD Card at \Honeywell\ezconfig\generated if
these files do not already exist.

1. Tap Launcher > Power Tools > EZConfig Utils.

2. Select the XML file to edit.

3. See XML File Structure (page 3-2) and Editing XML Files (page 3-3) for information on using the editor.
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EZConfig Editor on the PC (Workstation)
Overview
EZConfig Editor creates, edits, and manages EXM files for Dolphin terminals. There are two versions of EZConfig Editor: one
for the Dolphin terminal and one for the workstation. In the workstation editor, EXM files are edited, saved, then transferred to
the Dolphin terminal. In the terminal editor, EXM files are edited and saved right on the Dolphin terminal.

This chapter details EZConfig Editor running on a PC or workstation. Refer to EZConfig Editor on the Dolphin
Terminal beginning on page 3-1 for information about using EZConfig Editor on a Dolphin terminal.

Installing EZConfig on the Workstation
1. Access the Honeywell web site at www.honeywellaidc.com, then locate the product page for your Dolphin model.

2. Select the Software tab.

3. Under the Tools and Utilities heading, click on the listing for EZConfig for Mobility Setup.

4. Follow the security directions as prompted on the screen and click on Download.

5. When prompted, select Save, then select a location on your PC (e.g., your desktop).

6. Double click on the downloaded EZConfig for Mobility Setup.zip file.

7. Double click on the Setup.exe file. Select OK.

8. Follow the screen prompts to install the EZConfig for Mobility program.

Upgrades
Upgrades for EZConfig Editor on the workstation are available from Technical Assistance (see page 11-1) or www.honey-
wellaidc.com.

XML Files
The XML file format is an XML format customized for Dolphin terminals that is comprised of sections that sometimes contain
child sections and keys. Keys contain the values that configure the terminal.

The XML file format supports a multi-level, hierarchical, tree structure. The terminal reads the highest level section first and
then reads the key values in each section.

Opening EZConfig Editor on the Workstation
After you complete installation, EZConfig Editor is available on the workstation from the Start menu.

The EZConfig Editor can be used with EXM files and XML files. This document concentrates on the XML files for devices
powered by Android. Some functions of the EZConfig editor on the workstation are not applicable to these devices and are
not covered here.

Click Start > Programs > Honeywell > EZConfig for Mobility > EZConfig for Mobility.
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Menus and Toolbar Options

Edit Menu
For Section Edit menu options, see Working with Sections on page 4-4. For Key Edit menu options, see Working with Keys
on page 4-7.

Menu Item
Toolbar
Item

Description

New Creates a new document. There are two options:
• Configuration Document - Creates a configuration file. See

Creating New Configuration Documents (page 4-9).
• Registry Document - Not used.

Open Opens an XML file located on the workstation.

Recent Lists the recent opened with the EZConfig Editor.

Open from Device Not available.

Save Saves the open file to the location you select on the workstation.
This option is disabled for new and imported files; use Save As instead.

Save As Saves the open file with a new name to the location you select on the workstation.

Save to Device As Not available.

Properties Not available.

Create EZConfig
Bar Code

Embeds the open XML file in an Aztec bar code. See Generating Bar Codes on page
4-11

Exit Closes EZConfig Editor.
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View Menu

Tools Menu

Opening XML Files
EZConfig Editor opens XML files stored on the workstation or the terminal (if USB storage is turned on).

Opening XML Files on the Workstation

Click File > Open or the Open toolbar button and select the XML file.

Note: By default, EZConfig Editor only searches for EXM files. To open an XML, change the file type from EasyXml
files (*.exm) to All files (*.*).

Opening Remote XML Files
The workstation and the terminal must be connected and USB storage turned on.

EZConfig Editor can open XML files located on the terminal so that you can make edits to the terminal’s configuration
real-time. Browse to the drive that corresponds to the SD card on the device.

To open, double-tap on a file or select it and click OK.

Note: You can also open XML files in the editor on the terminal; EZConfig Editor on the Dolphin Terminal beginning on
page 3-1

Menu Item Description

Show Locks

Shows or hides the icons indicating if a subsection or key is locked.

For additional information on locks on subsections and keys, see Status Bar on page 4-4.

Menu Item Description

Simplify Document

Important
You cannot undo this
action

Simplifies the XML file, which makes it smaller. Simplifying permanently removes
• Disabled sections and keys
• Descriptions
• Bar code settings
When you create a bar code, you can simplify the file embedded in the bar code without affecting
the open XML file. This reduces the size of the bar code package yet keeps the disabled sec-
tions, descriptions, and bar code settings in the open XML file for future reference.
See Simplified (page 4-12) on the Bar Codes Tab.

Launch Associated
Application

Not available.

Warm Boot Not available.

Cold Boot Not available.

The lock icon means the section’s
subsections are locked.The key icon means that the

section’s keys are locked.
4 - 3



Working with Open XML Files
EZConfig Editor displays the content in four different sections of the window.

Status Bar
The Status Bar appears at the bottom of the window and displays information about selected sections and keys.

Selected Section

See Section Locks on page 4-6.

Selected Key

See Key Types on page 4-9.

Working with Sections
The XML file format supports a multi-level tree structure. The section tree appears in the top left quadrant of the window.
The root node identifies the XML file and “Root” appears in the description.

Sections have a Name and Description and contain keys that appear in the upper right quadrant when you select the sec-
tion name. Select a section by clicking on it. You can select only one section at a time.

Edit Menu Options
Select a section. Click Edit to see the available options.

Menu Item Description

Rename Activates the section name so that you can rename the section.
Note: You cannot modify the name if the section is locked; see Section Locks (page 4-6).

Displays the root node
and sections.

Select a section and the
details appear in the
other portions of the
window.

The folders appear in
different colors to
indicate their status.

Displays the section
name and description.

Displays the keys in
the selected section.

Text that appears in
blue can be edited.

Displays the selected
key’s name and
description.

Displays the file name.

Status Bar

Section Name Merge Mode Locks on subsections and keys

Key Name Enabled or
Disabled

Read Only Encrypted Key locked by
section
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Modifying Section Names
To change a section name, double-click on the folder and type in the new name or select Rename on the Edit menu.
Type in the new name and press ENTER.

Note: You cannot modify the name if the section is locked or disabled; see Section Locks (page 4-6).

Modifying Section Descriptions
Descriptions are not required to process key values but do help document the XLM file and often contain valuable infor-
mation. If you want to modify a section description, select the section, click inside the section description, and begin
typing. You cannot modify descriptions of locked sections.

Cut Cuts a selected section.

Copy Copies a selected section.

Paste Pastes the section that was just cut or copied at the same level as the selected section.

Paste as Child Pastes the section that was just cut or copied as a child of the selected section.
Note: You can cut, copy and paste sections within an XML file or across XML files.

Delete Deletes a selected section.
Note: Because you cannot undo a delete, consider disabling (see Disable All on page 4-5)

rather than deleting.

Enable Sections are enabled by default. This menu item enables sections that were previously dis-
abled. You can enable a section only if its parent section is enabled.
To enable all the keys inside a section you are enabling, SHIFT + right-click and select Enable
All.

Disable All Sections are enabled by default. This menu item disables sections and all of its keys.
Disabled sections remain in the file with a gray folder. .

If you disable a section that has child sections, all of its child sections (and the child section
keys) are disabled automatically. The child section folders are also in gray.
When reading the XML file, the terminal behaves as though disabled sections are not there and
moves on to read the next enabled section.
Disabled sections can be removed from the XML file permanently using the Simplify Document
(see page 4-3) option. If you want to keep disabled sections in the XML file on the workstation
but not in the file deployed to the terminal, use the Simplified option (see page 4-12) when cre-
ating the bar code.

Insert Section Inserts a new section. You can also press the Insert key (INS).

Append Child
Section

Adds a new child section to a selected section. The new child section is inserted below the
previous section.

Menu Item Description
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Moving Sections
To move sections within an XML file, use the drag and drop method. By default, sections are dropped at the same level
in the tree.

For additional functionality when dragging and dropping, press and hold:

• ALT to drop a section as a child section.
• CTRL to copy a section and drop the copy at the same level in the tree.
• CTRL + ALT to copy a section and drop the copy as a child section.

Note: You can select only one section at a time; you cannot use SHIFT+Click or CTRL+Click to select more than one
section.

To move sections between XLM files, open two instances of EZConfig Editor and drag and drop sections between
them. When dragging, a copy of the section is dragged to the new file. When dropping, drop the section directly on top
of the section of which you want it to be a child section.

Note: To drop the first section into a new file, press and hold the ALT key and drop the section on the root node. (All
sections must be child sections of the root node.)

Section Locks
There are different types of locks on sections. The status bar indicates what type of lock is applied to a selected sec-
tion.

Note: All locks are applied to each individual section and are not recursive. Only text that appears in blue can be
modified.

Section-Level Merge Modes
XML files ship with section-level merge modes already defined according to section content. Merge modes determine
how section information is handled when an updated XML file is deployed to the terminal where an existing version of
that XML file is stored.

Merge modes are indicated by folder icons and in the Status bar.

Lock Type
Status Bar
Indicator

Description Effect

Name Lock The section name is
locked.

Section Name and Description cannot be modi-
fied.

Key Lock All keys are locked. Key Names and Descriptions cannot be modified.
Keys cannot be added, moved, or deleted within
the section.

Subsection
Lock

All immediate subsections
are locked.

Immediate subsection Names and Descriptions
cannot be modified. Immediate subsections can-
not be added, moved, or deleted.

Mode Description Merge Effect

Delete + Add Deletes non-common children elements (i.e., subsections, and keys) in the
target file, then adds the new information from the bar code. Basically, the
new section replaces the old section.
This is the default merge mode for new sections.

Exclusive

Disable + Add Disables non-common children elements (i.e., subsections, and keys) in the
target file, then adds the new information from the bar code.
Note: Disabled sections and keys removed from the simplified bar code end

up as disabled in the target file.
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To change section-level merge modes, select a section and right click.

The folder colors change immediately after selection.

Working with Keys
Keys have a Name, a Description, and a Value and reside inside sections. For specific key values, consult the chapters of
this user’s guide that describe the XML file you’re attempting to edit.

Edit Menu Options
Select a key and right-click or click Edit to see the available options.

Add Only Adds new information (sections and keys) to the existing section. If this is a
brand new section, the new section is added to the existing XML file.
Note: Disabled sections removed from the simplified bar code are not

modified in the target file.

Inclusive

Menu Item Description

Rename Activates the key name so that you can rename the key. Rename is disabled if the key is
locked or disabled; see Key Types (page 4-9).

Cut Cuts a selected key.

Mode Description Merge Effect

The same options
appear on both
menus.
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Modifying Key Names
To modify key names, double-click on the key name or select Rename on the Edit menu. Type in the new name and
press ENTER or TAB.

Note: You cannot modify the description if the key is locked; see Key Types (page 4-9). Only text that appears in blue
can be modified.

Modifying Key Values
You can modify a key value only if its text appears in blue. In that case, double-click on the value or select the key and
press ENTER. Type in the new value and press ENTER or TAB to save.

Modifying Key Descriptions
Descriptions are not required to process key values but do help document the XML file and often contain valuable infor-
mation. To modify a key’s description, click on the key, then click in the key description area. When the cursor is
active, you can type in the text.

Note: You cannot modify the description if the key is locked; see Key Types (page 4-9).

Moving Keys
To move keys within an XML file, use the drag and drop method. Press and hold the CTRL key to drag and drop a copy
of the key to the new location.

Note: You cannot move a key if it is locked by its section.

To move keys between XML files, open two instances of EZConfig Editor and drag and drop keys between them.
When you select the key and drag, a copy of the key is dragged to the new file. In the new file, drop the key in the key
area of a selected section; keys are always dropped at the same level within a section.

Copy Copies a selected key.

Paste Disabled; keys can be pasted only as children of a section.

Paste as Child Pastes the key just cut or copied in the selected section. Keys are not multi-level; all keys
paste at the same level within a section.
You can cut, copy and paste keys within an XML file or across XML files.

Delete Deletes a selected key.
Note: You cannot undo a delete; you might want to consider disabling rather than deleting.

Enable Enables keys that were disabled. When a key is enabled, the client application can read and
apply its value. When you enable a key, make sure to specify a value for that key; do not
leave it blank.

To enable a key, its parent section must be enabled.

Disable Disables keys.
Disabled keys have key values in black. Enabled keys have key values in blue.

The terminal does not read disabled keys, and disabled keys are removed if the file is simpli-
fied; see Simplify Document (page 4-3).

Because many key values are 1 for enable and 0 for disable, remember that disabling a key
means that the terminal behaves as if the key is not there when reading the file, NOT that the
key’s value is set to disabled. The terminal simply moves on to read the next enabled key.

Insert New Key This menu item inserts a new key above the selected key.
Note: You can also press the Insert key (INS).

Menu Item Description
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Key Types
When a key is selected, its properties display in the Status bar.

Note: Locked and Read Only properties are not recursive. Properties are applied to each individual key. Only text that
appears in blue can be modified.

Saving to the Device
You can save XML files directly to the terminal only when USB storage is activated between the terminal and the worksta-
tion. Select File > Save As and browse to the drive that corresponds to the SD card on the Dolphin terminal.

Select the location on the terminal where you want to store the file and click OK. The file is downloaded directly to the ter-
minal.

Note: XML files for Power Tools must be stored in the active storage folder. See Storage Locations (page 1-3).

Creating New Configuration Documents
To create new XML files that are configuration documents, you can open an existing XML file and save it with a new name
or create an XML file from scratch.

Lock Type
Status Bar
Indicator

Description Effect

Name Lock Keys are locked by the section. • Name and Description cannot be
modified.

• Keys cannot be added, moved, or deleted
within the section.

The key name is locked indi-
vidually.

• Name and Description cannot be
modified.

• These keys can be moved.

Read Only Read-only keys cannot be
modified in any way. They ap-
pear in red.

• Name, Description, and Value cannot be
modified.

• Keys cannot be added, moved, or deleted
within the section.

Encrypted Key’s value appears as aster-
isks (*) for added security.

Note: Encrypted keys are also stored
encrypted in the XML file. If you open
the XML file in a text editor, you won't
see the data as clear text.
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1. Click File > New > Configuration Document. The root node is created and appears as the top level section. All sec-
tions must be at least one level down from the root node. The name of the root node is always the same as the file-
name.

2. To create the first subsection, select the root node, right-click, and select Append Child Section.
Insert Section is disabled because you cannot insert sections at the same level as the root node.

3. Enter a Name and a Description and click OK.
The name is required, the description is optional.

4. To add a new section at the same level, right-click and select Insert Section.
To add a new section one level down, right-click and select Append Child Section.

5. To add keys, select a section, right-click in the key value section, and select Append Key.

6. Enter the Name, Value, and Description and click OK.
The name is required; the description is optional.

7. Continue adding sections and keys.

8. If necessary, associate this XML file with an application; see Creating Bar Codes (page 4-10).

9. Click File > Save As to save the file.
Save is disabled so that you save the document with a name other than NewDocument.xml.  

Creating Bar Codes
EZConfig Editor embeds XML files in bar codes. The EZConfig Client on the terminal decodes the bar code and deploys the
data. Using bar codes quickly and easily configures Dolphin terminals without a connection to a workstation.

Bar Code Type
EZConfig Editor creates an Aztec bar code.

Time and Date Stamp
XML files are stamped with the time and date the moment EZConfig Editor creates the bar code.

Bar Code Size and Number
The amount of data in the XML file determines how many bar codes are generated and the physical size of each bar code.
More data means more bar codes and larger bar codes.

EZConfig Editor offers four ways to control how many bar codes are produced and adjust the size of each bar code:

The terminal reads
root node first.

The Description
says “Root” to
indicate that this is
the root section.
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1. Set byte size limits on how much data each bar code can contain—see Max Bar code Size on page 4-12.

2. Split the data across a specified number of bar codes—see # Bar codes to generate on page 4-12.

3. Simplify the XML file in the bar code—see Simplified on page 4-12.

4. Scale the bar codes on the bar code sheet—see Bar Code Scaling Factor on page 4-13.

Bar Code Sheet
EZConfig Editor produces a bar code sheet that contains the generated bar codes. Bar code sheets can be printed from a
laser printer, copied to the clipboard, and saved as an HTML file; see Printing and Saving Options on page 4-13.

In addition, individual bar codes can be saved as TIF or PNG graphic files that can then be emailed and printed; see Bar
Codes Tab on page 4-11.

Generating Bar Codes
When creating a bar code, EZConfig Editor automatically encrypts and compresses the data in the XML file. To generate a

bar code, click File > Create EZConfig Bar Code OR the Create Bar Code toolbar button while the XML file is open.
EZConfig Editor generates a bar code or codes. The Bar Codes tab window opens displaying the details of the bar code
package generated.

The Bar Codes and Advanced tabs offers several processing options.

Note: The number of bar codes produced depends on the amount of data present in the XML file. The more data present,
the more bar codes generated. You must scan all bar codes to deploy the package.

Bar Codes Tab
The Bar Codes tab previews and customizes generated bar code(s).

Field/Option Description

Display Indicates which bar code is displayed in the preview area; the default is “1,” the first bar code in
the package. If more than one bar code was generated, you can use the up and down arrows to
scroll through the bar codes.

(___ bytes) Displays the exact byte size of the bar code displayed in the preview area.
Total Package Size (page 4-13) is displayed at the bottom of the window.
Note: The sum of bar code size is typically larger than the package size.

Remote Path Type in the active storage location and filename where the XML file should be deployed on the
terminal. For example:
\Honeywell\deviceconfig.xml
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Advanced Tab
The Options tab contains settings that tell EZConfig Client how to process the XML file on the terminal.

Full Contents Includes the full content of the XML file in the bar code, without simplifying.

Simplified Simplifies the XML file in the bar code, which removes disabled sections, description information,
and bar code settings (if any), which decreases the size of the bar code. The open XML file is not
simplified.
Simplified is selected by default.

The differences in total package size are displayed in the Package Size (page 4-13) field.

Individual bar code size can be seen in the Display (page 4-11) field.

# Bar codes to gen-
erate

This slider is active only if the Always use minimum # bar codes (see page 4-12) is not selected.
When this slider is active, you can move the slider toward minimum or maximum to change the
number of bar codes generated. As you move the slider, you’ll see the number of bar codes in the

counter at the bottom of the window and you’ll notice the graphic of the bar code in the
preview area change.

Copy to Clipboard Copies the bar code displayed in the preview area to the clipboard.
Use this option to paste the bar code into another application.

Save Saves the bar code displayed in the preview area as a graphic file (.png or .tif).
By default, the name of the graphic file is the same as the name of the open XML file. You can
enter a different name when saving.

Save All Saves all bar codes in the package as individual graphic files.
By default, the graphic files are saved with the same name as the open XML file with a number at
the end to distinguish the individual graphic files from each other.

Print Opens the printing window where you can select print options and print the bar code package. For
details, see Printing and Saving Options on page 4-13.

Field Description

Bar Code Options–This section determines some of the basic bar code parameters.

Max Bar code Size Sets the maximum amount of data (in bytes) one bar code can contain. The lower the number of
bytes, the smaller the bar code.
• On the Bar Codes tab, bar code size appears in the Display field (see page 4-11).
• The total number of bar codes created as a result of the max bar code size limit appears at the

bottom of the Advanced window; see Bar Codes (page 4-13).

Always use mini-
mum # bar codes

This option is selected by default. It calibrates the data so that the minimum number of bar codes
are used. When this option is selected, the number of bar codes slider on the Bar Codes tab is
disabled.

Use custom pass-
word

This option enables you to password-protect the bar code you’re creating.
Select this option, then enter the password in the field provided. You will be able to see the pass-
word when you enter it; however, you will not be able to see the password again once you close
the window because the password will be encrypted. Passwords must contain 16 characters.

If you password-protect the bar code, use the EZConfig Client to enter the password. See Set
Custom Password on page 5-2. If the passwords do not match, a “This config file is not supported”
message is displayed.

Full screen prog-
ress dialog

This option runs the deployment progress dialog box on the terminal in full screen mode so that the
user cannot open another application while the bar codes are being deployed on the terminal.

Warm boot after
finished

This option is not supported.

Deployment Options–These options determine how to deploy the XML file on the terminal.

Field/Option Description
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Information at the Bottom of Tab Windows

Printing and Saving Options

On the Bar Codes tab, when you click Print, a bar code printing window opens offering you a number of printing options.

Merge each sec-
tion…

(Default selection)

Deploys information according to the section-level merge mode settings; see Section-Level Merge
Modes on page 4-6.
If already exists, deploy:
• Always–Select to always use the section-level merge mode settings.
• Only if newer–Select to use the section-level merge mode settings only if the sections are

newer than the existing file.

Temporary Deploys the XML file temporarily. The settings in the XML file are applied, but the file does not re-
main in the system after EZConfig Client is done.

If the terminal contains a previous XML file with the same name, the previous XML file is preserved.

If already exists, deploy–This section determines how the XML file will be deployed if an XML file of the same name in
the same location exists on the terminal.

Replace remote
file

Replaces the existing file; no section-level merge modes are applied.
If already exists, deploy:
• Always–Select to always replace the existing file.
• Only if newer–Select to replace the existing file only if the file in the bar code is newer than the

existing.
• Never—Do not deploy the new file; this preserves the existing file.
• Prompt—EZConfig Client asks the user if they want to overwrite the existing file during

deployment.

Persist Bar Code Settings

Stores the settings from the Options, Bar Codes, and Web Page tabs within the XML file so that the same bar code settings
are applied the next time a bar code is created. This increases the size of both the XML file and the bar code(s).

If the Simplify option is selected, bar code setting information is not included in the bar code but remains in the open XML
file.

Field Description

Package Size Displays the total size of the bar code package. This number changes with simplifying.

Compression On Notifies you that compression and encryption are both on.
Compression and encryption are always on by default. EZConfig Editor uses 128-bit encryp-
tion automatically.Encryption On

Bar Codes Displays the total number of bar codes generated. This number changes as you move the
slider on the Bar Codes tab.

Field/Option Description

Preview Area This is the largest section of the tab window and displays a preview of the bar code sheet. Use
the scroll bars to see all the bar codes.

Header Type in a custom header for the page.

Footer Type in a custom footer for the page.

Bar Code Scaling
Factor

Adjusts the size of each bar code by scaling all of them up or down, which determines how many
bar codes can fit on each page. This does not change the amount of data in each bar code, just
the size of the bar code on the page.

Field Description
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Save Saves the bar code sheet as an HTML file.

Preview Click to see a print preview. Click Print on this window to print your bar codes.

Field/Option Description
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5

EZConfig Client
Overview
EZConfig Client decodes bar codes created in EZConfig Editor and deploys the data in the terminal. In addition, if the EXM file
in the bar code is associated with an application, EZConfig Client launches that application, which then processes the decoded
data.

EZConfig Client decodes bar codes with 40-bit and 128-bit encryption.

Using EZConfig Client

1. Tap Launcher > Power Tools > EZConfig. The EZConfig Client window opens.

2. Point the terminal at the first EZConfig Editor bar code, then press the SCAN key.

3. EZConfig Client decodes the bar code.

4. If there is only one bar code in the package, EZConfig Client deploys the package. If there is more than one bar code in the
package, EZConfig Client decodes the bar code, records that one bar code has been read, and waits for the next scan.

5. Scan all the bar codes in the package. Bar codes can be scanned in any order.

6. When all bar codes in the package have been scanned, the EZConfig client deploys the data.

XML File Processing
After decoding, EZConfig Client saves the XML file to the terminal as \honeywell\configure.xml.

Multiple Bar Codes
Some XML files generate more than one bar code. If multiple bar codes were generated, EZConfig Client recognizes that
there is more than one bar code in the package and tracks each bar code scanned and decoded. Bar codes can be
scanned in any order, but EZConfig Client does not deploy the data until all the bar codes in the package have been
scanned.

EZConfig Client Window

Field Description

Is EZConfig barcode Identifies the scanned bar code as an EZConfig bar code.
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Set Custom Password
Press the MENU key then tap Set custom password.

If the bar code to be scanned has a password, the same password must be entered here or the bar code won’t be pro-
cessed.

To enable the password on the terminal:

1. Check the Set custom password checkbox.

2. Enter the password in the text box. Passwords are case sensitive.

3. If the password entered does not match the password used when the bar code was created, the device displays “This
config file is not supported”.

Browse Configure Files
Press the MENU key then tap Browse configure files.

Browse and select the XML file to edit.

See XML File Structure (page 3-2) and Editing XML Files (page 3-3) for information on using the editor.

About
Press the MENU key then tap About to display information about the EZConfig Power Tool.

Total barcodes Displays the total number of bar codes in the set.

Current barcode Identifies the last bar code scanned.

Scanned barcodes Identifies all bar codes in the set that have been scanned.

Field Description
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6

Autorun and AutoInstall
Overview
Startup is the launch sequence when a Dolphin terminal is booted. There are two startup Power Tools:

1. Configure Autorun

2. AutoInstall

Configure Autorun
Configure Autorun specifies the applications to launch after each reboot. Applications that may be selected for Autorun include
Power Tools and Demos.

Additionally Autorun Configure can enable the Restore and DeviceConfig functions upon reboot.

Autorun Applications

Tap Launcher > Power Tools > Configure Autorun.

The available applications that can be selected for Autorun are displayed. By default, all user applications are listed on the
Normal screen. Applications that are on the Normal screen do not run automatically. The Autorun screen displays any
applications that are configured for Autorun. Toggle between the screens by tapping the Normal and Autorun icons at the
top of the screen.

To configure an application to Autorun:

• From the Normal screen, tap and hold the application on the list.
• When the popup message displays asking if the application should be added to the Autorun list, tap Yes to confirm.

When an application is configured to Autorun, the listing for that application is removed from the Normal screen and it is
then displayed on the Autorun screen.

Likewise any application that is configured for Autorun can be removed by a similar process:

• From the Autorun screen, tap and hold the application on the list.
• When the popup message displays asking if the application should be added to the Normal list, tap Yes to confirm.

The application is removed from the Autorun list and added to the Normal list.

Enable Restore

Tap Launcher > Power Tools > Configure Autorun, then press the MENU key and select Setup. Make sure
the checkbox is checked for Enable Restore. When enabled, the Restore function searches the \Honeywell\backup 
folder on the Dolphin terminal’s SD card for restore files after rebooting.

To create backup files for the restore function, see Backup on page 7-1.

Enable DeviceConfig

Tap Launcher > Power Tools > Configure Autorun, then press the MENU key and select Setup. Make sure
the checkbox is checked for Enable DeviceConfig. When enabled, the Restore function searches the \Honey-
well\ezconfig folder on the Dolphin terminal’s SD card for a device configuration files (DeviceConfig.xml) after
rebooting. If the configuration file is found, the settings in the file are applied to the terminal.
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AutoInstall
AutoInstall is an option in the Settings menu screen.

Tap Launcher > Settings > AutoInstall Settings.

If AutoInstall is enabled, the \Honeywell\autoinstall folder on the Dolphin terminal’s SD card is searched for zip files
containing applications. Each zip file is compared to the applications presently installed on the Dolphin terminal:

• If the application is not installed, AutoInstall installs the application.
• If the application is already installed, AutoInstall checks to see if the zip file contains a newer version of the application and

installs the newer version.
• If the application is already installed and there is not a newer version, AutoInstall ignores the installation file.

If AutoInstall is not enabled, the contents of the \Honeywell\autoinstall folder are ignored.
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Backup and Restore Power Tools
Overview
The backup and restore power tools provide a utility for the backup and restoration of settings and user data on the terminal.
The following items can be included in the backup:

• Call Logs
• Contacts
• Messages
• System Settings
• Music Playlists
• Browser Bookmarks
• Wi-Fi firmware configure file
• Wi-Fi daemon APP configure file

Tap Launcher > Power Tools > Backup to access the Backup and Restore screen.

Backup
To perform a backup:

1. Tap Backup from the Backup and Restore screen.

2. Select Device or SD Card for the location to store the backup. If the backup is stored on the device, the backup is lost when
a Factory Data Reset is performed. A backup stored on the SD card is preserved after a Factory Data Reset.

3. Select Add New Backup or select an existing backup to replace.

4. If a new backup is being created, enter a filename for the backup file.

5. If an existing backup is being replaced, confirm the replacement.

6. From the Selection screen, choose the settings and/or data to be included in the backup.

7. Tap Continue to perform the backup or Cancel to exit the backup.

Note: If the backup is to be used with the auto restore function, either create the backup in the \Honeywell\backup folder
on the SD card or create the backup file elsewhere and copy it to that directory.

Restore
To perform a restore from a previous backup:

1. Tap Restore from the Backup and Restore screen.

2. Select Device or SD Card for the location of the backup file to restore.

3. Select an existing backup to restore.

4. From the Selection screen, select the items from the backup to be included in the restore process.

5. Tap Continue to perform the backup or Cancel to exit the backup.
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Schedule

To enable auto restore after a reboot, tap the Schedule icon and select OK. When enabled, the \Honeywell\backup 
folder on the Dolphin terminal’s SD card is searched for a backup to restore after the terminal is rebooted.

About

Tap the About icon to display information about the Backup Power Tool.
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Network Utilities
Accessing Network Utilities
The following Network Utilities configure the network connection(s) in the terminal:

• Connection Manager (see below)
• Wi-Fi Radio Settings (see below)
• Wireless Manager (see page 8-3)
• Remote MasterMind© (see below)

These Network Utilities mirror DOS-prompt functions on your workstation:

• IP Config (see page 8-6)
• Ping (see page 8-7)
• Route (see page 8-8)

Remote MasterMind©

The bootstrap.xml file is used to configure your Dolphin terminal to communicate with Honeywell’s Remote MasterMind device
management software. Remote MasterMind gives you the power to manage mobile computers, smart phones and bar code
scanners across multi-site enterprises. Refer to http://remotemastermind.honeywellaidc.com/Help/v4.0/en/default.htm for fur-
ther information about using Remote MasterMind and configuring the bootstrap.xml file.

Connection Manager
Connection Manager lets you switch between WiFi and cellular carriers. It also lets you control radio power and hyper roaming.

Radio Power
Slide the switch to turn the radio on or off. Tap the Radio Power title to view the radio’s status and network settings.

Hyper Roaming
This feature is used to determine when to scan for available networks, or when to switch networks. Hyper Roaming con-
trols connectivity based on RSSI settings or on the network type.

Tap Connection to select a 2G or 3G connection. Tap RSSI settings to input the RSSI threshold and dwell time.
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Firmware Manager
Tap this selection to change the device firmware.

Wi-Fi Radio Settings
This tool provides several options to configure the Wi-Fi radio in the Dolphin terminal.

2.4GHz Channel
Identify the channels to be used for 2.4GHz communication. By default channels 1 through 14 are enabled.

Tap the checkmark on the right to disable a channel.

5GHz Channel
Identify the channels to be used for 5GHz communication. By default, all channels are enabled. Channels are categorized
by UNII-1 (36, 40, 44, 48), UNII-2 (52, 56, 60, 64), Extended (100,104,108, 112, 116, 120, 124, 128, 132, 136, 140) and
UNII-3 (149, 153, 157, 161, 166).

Tap the checkbox to on the right to disable a channel.

Roaming
Roaming
Check to enable roaming. By default roaming is enabled.

Threshold 65(-dBm)
Enter the roaming threshold. The current value for this parameter is reflected in the title (i.e., 65).

If the signal strength is less than the value selected for threshold, the Dolphin terminal searches for another AP to
attempt roaming.

The default threshold is -65 dBm. To adjust this value, tap the down arrow.

Enter the desired threshold and tap OK to save or Cancel to discard.

AP Diff 10 (dBm)
Enter the amount by which the new access point signal strength must exceed the current access point before roaming
to the new access point is attempted. The current value for this parameter is reflected in the title (i.e., 10).

The default AP signal difference is 10 dBm. To adjust this value, tap the down arrow.

Enter the desired AP Diff value and tap OK to save or Cancel to discard.

Roam Scan Period 5000
Enter the period of time (in milliseconds) the Dolphin terminal collects scan data before a roaming decision is made.
The current value for this parameter is reflected in the title (i.e., 5000).

The default scan period is 5000 milliseconds. To adjust this value, tap the down arrow.

Enter the desired roam scan period and tap OK to save or Cancel to discard.

DFS Roaming
Check the checkbox to enable DFS (Dynamic Frequency Selection) roaming. By default DFS roaming is disabled.

Tx Rates
Identify the Tx rates to be used. By default all rates are selected. Tx Rates are categorized by CCK Rates (1, 2, 5. 5, 11
and 22 Mbps), OFDM Rates (6, 9, 12, 18, 24, 36, 48 and 54 Mbps) and DNM Rates (802.11n and MCS0 through MCS7).
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Tap the checkmark to on the right to disable a Tx rate.

Other
Power Save
Determines the power save mode used by the Wi-Fi radio. Options are Auto (default), Active, Short Doze and Long
Doze.

WMM/QoS
Determines if the radio uses Wi-Fi Multimedia extensions/Quality of Service. By default this option is enabled
(checked).

Random AP Selection
Determines if the Dolphin terminal associates with random access points. This option is disabled (unchecked) by
default.

Random AP Min RSSI 60
Specifies the minimum RSSI (Received Signal Strength Indication). A random AP must have a signal strength indica-
tor greater than this value before being considered for association. The current value for this parameter is reflected in
the title (i.e., 60).

The default minimum RSSI is -60 dBm. To adjust this value, tap the down arrow.

Enter the desired AP Diff value and tap OK to save or Cancel to discard.

Beacon Loss Count 30
Specifies the threshold for missed beacons. If the number of missed beacons exceeds this parameter, a scan for
another AP is initiated.

The default Beacon Loss Count is 30. To adjust this value, tap the down arrow,

Enter the desired Beacon Loss Count and tap OK to save or Cancel to discard.

Wireless Manager
This tool provides information about the Wi-Fi radio in the Dolphin terminal. When the Wireless & Network screen appears, an
arrow is displayed to the left indicating which wireless connection has the higher priority:
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To change the priority, press and hold on the text for the preferred connection.

Wi-Fi
Use this feature to turn Wi-Fi on or off and to configure the favorite access point list.

Turn Wi-Fi On/Off

Controls the status of the Wi-Fi radio. Tap the On/Off switch to change the status of the Wi-Fi radio.

Scan Result
Tap Wi-Fi to display the scan results. The list contains all discovered access points.

To forget an access point:

1. Tap and hold the access point name.

2. When the prompt is displayed, tap Forget to remove the access point from the list.

3. Tap Cancel to exit without removing the access point from the list.

To add an access point to the favorite list:

1. Tap by the access point name.

2. When the prompt is displayed, tap OK to add to the favorite list.

3. Tap Cancel to exit without adding the access point to the favorite list.

Favorite List

Tap the Favorite icon to access the favorite list.

Access points on the favorite list have a higher priority for connection.

To remove an access point from the favorite list:

1. Tap and hold the access point name.

2. When the prompt is displayed, tap Forget to remove the access point from the list.

3. Tap Cancel to exit without removing the access point from the list.

GPRS
This feature is not currently supported.
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AP Info
Tap AP Info for information on the connected and scanned access points.

The information list is displayed. Tap the Scan icon to manually initiate a scan for access points.

Connected AP
If the Dolphin terminal is currently connected to an access point, information on the connected access point is dis-
played at the top of the screen, with a darker background. Information is displayed on the currently connected access
point including SSID, BSSID, IP address, channel number and signal strength.

If the Dolphin terminal is not currently connected to an access point, the darker area at the top of the screen indicates
there is no active connection. Additional information may be displayed indicating if the terminal is scanning for an
access point or if Wi-Fi is not enabled.

Scan Results
Below the darker area are any discovered access points. For each access point the following information is displayed:
SSID, BSSID, signal strength, encryption type, 802.11 band and the number of times this terminal has connected to
the access point since the last reboot.

Connection Info
Tap the connected AP for connection information. Information displayed includes DHCP details, link speed, etc. This
information is periodically refreshed.

Configuration Info

Tap the Next button to view the configuration information.

This screen displays encryption and other security information for the Wi-Fi connection.

Tap the Previous button to return to the connection information.

Roam Tracker
Roam Tracker displays detailed information on the current access point and roaming information.

The top of the screen displays the SSID, BSSID, RSSI and IP address of the currently connected access point.

The next section displays the number of BSSID changes and connection time-related parameters.

The bottom section is a table listing any access points that have been discovered. The first access point is listed in bold
and blue. This is the currently connected access point.

For each access point, the screen displays the BSSID, channel and count (the number of times the Dolphin terminal has
connected to this access point since last reboot).

Tap the Scan icon to manually initiate a scan for access points.

Connected AP

Scanned APs
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Send/Receive Status
The total quantity of data sent and received via the Wi-Fi connection since the last reboot is displayed.

IP Config
IPConfig is a kernel utility that displays, releases, and renews IP parameters for on-board network adapters.

Settings

Press the MENU key then tap Settings on the options menu.

Clear
Press the MENU key and tap Clear on the options menu. Clears (releases) the DHCP configuration for the current adapter.

Refresh
Press the MENU key and tap Refresh on the options menu. This option refreshes (renews) DHCP configuration for the
adapter.

Field Description

Adapter This drop down list contains the network adapters currently installed in the Dolphin terminal. Every
field and button on this screen pertains to the adapter selected in this drop down list.

MAC Addr Displays the MAC (Media Access Control) address of the selected Adapter. This is the serial num-
ber burned into the adapter that uniquely identifies it.

IP Addr Displays the IP (Internet Protocol) address of the selected Adapter.

Flags Displays the interface flags.
0x1 /* interface is up*/
0x2 /* broadcast address valid*/
0x4 /* turn on debugging*/
0x8 /* is a loopback net*/
0x10 /* interface is has p-p link*/
0x20 /* avoid use of trailers*/
0x40 /* interface RFC2863 OPER_UP*/
0x80 /* no ARP protocol*/
0x100/* receive all packets*/
0x200/* receive all multicast packets*/
0x400/* master of a load balance*/
0x800/* slave of a load balancer*/
0x1000/* Supports multicast*/
0x2000/* can set media type*/
0x4000/* auto media select active*/
0x8000/* dialup device with changing addresses*/
0x10000/* driver signals L1 up*/
0x20000/* driver signals dormant*/
0x40000/* echo sent packets*/

Field Description

Use static IP Check to enter static IP information. When unchecked, DHCP is used.

IP Addr Tap the down arrow and specify the IP address.

Netmask Tap the down arrow and specify the netmask in IP address format.

Dest address Tap the down arrow and specify the dest address in IP address format.
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About
Press the MENU key then tap About on the options menu

The About screen displays information about the IP Config Power Tool.

Ping
Ping provides a GUI-based version of the traditional command line ping utility. Pinging sends out an echo request to a specific
computer on the network. Use Ping to verify communication links or that a specific IP address is working.

Using the Ping Utility

Settings
Press the MENU key then tap Settings on the option menu.

Note: You do not need to complete all the fields on the Ping window to successfully execute. The only necessary entry is
the Destination IP address.

Clear
Press the MENU key then tap Clear on the options menu.

Clears the ping results. If an active ping is in process, the ping continues.

Field Description

Input destination Enter the IP address. This field is required.

ping Starts the ping utility. Once started, this button is labeled stop. Tap the stop button to stop
the ping utility and display the ping statistics.

Field Description

Timeout (seconds) Enter the timeout time in seconds.

Send packet size Indicate the packet size for sending; 64 is the default.

Send count Indicate the count for sending; Infinite is the default.

TTL Enter the Time To Live (TTL). TTL is the maximum number of times a packet is allowed to
travel through the network before it is discarded.

ToS Enter the Type of Service (TOS); it should be eight bits broken into five subfields.

Record route Check the checkbox to record the router addresses where the packet transfers.

MTU discovery Select the path Maximum Transmission Unit (MTU) discovery. Options include:
• Do prohibit fragmentation, even locally
• Do Path MTU (PMTU) discovery, fragment locally
• Do not set the Don’t Fragment (DF) flag.

Pinging a broadcast
address

Check the checkbox to ping the broadcast address, which means all hosts in the network
respond to the ping.

Wait seconds Indicate the wait interval between sending each packet.
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About
Press the MENU key then tap About on the options menu.

The About screen displays version information about the Ping Power Tool.

Route
Route is a kernel utility that allows the user to view and edit the rules that govern how packets destined for various subnets are
routed. These rules tell the device which gateways (on a given interface's subnet) that may be used to route packets to hosts on
other subnets.

Add

Delete
This option deletes the selected route.

Delete can also be accessed by pressing the MENU key then tapping Delete.

Delete All
Press the MENU key then tap Delete All.

This option deletes all routes.

Refresh
Press the MENU key then tap Refresh.

This option refreshes the Route list.

About
Press the MENU key then tap About.

Displays information on the Route Power Tool.

Field Description

Destination Enter the destination IP address.

Mask Enter the mask in IP address format.

Gateway Enter the gateway IP address.

Metric
Determine whether one route should be chosen over another by assigning a priority (1-
9999).
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ScanWedge
Overview
ScanWedge sends data from the decoder interface to the foreground application as keystrokes (as if the data were entered via
the keyboard). The foreground application is the open software application whose window is currently active on the display.

As a result, you can review input data in applications such as messaging, email or third-party text entry applications.

Enabling ScanWedge
When ScanWedge is enabled (the checkmark appears), a smaller ScanWedge icon appears in the notifications area at the top
left corner of the screen. By default ScanWedge is disabled.

This icon provides a shortcut to access the ScanWedge screen.

Enabling ScanWedge at Startup
To run ScanWedge automatically when the Dolphin terminal boots up, add ScanWedge to the Autorun list in Configure
Autorun (see page 6-1)

Disabling ScanWedge
Navigate to the Power Tools Main Window (see page 1-1) and tap the ScanWedge icon again.

OR

Pull down the notification bar and tap the ScanWedge notification to open the application and disable it.

When ScanWedge is installed, a ScanWedge.xml file is inserted in permanent storage (see Storage Locations on page 1-3).
This file specifies configuration parameters for ScanWedge and must not be moved.

Use EZConfig Editor on the workstation to modify ScanWedge.xml. For more information, see Working with Open XML Files on
page 4-4.

Menu Item This item …

Enable Enables and disables ScanWedge without exiting ScanWedge.

General Settings Configures prefix and suffix settings, enables and disables scan notifications, formatting and cen-
tering window.

Symbology Settings Enables and disables bar code symbologies. Configures symbology specific bar code settings.

About Opens the About screen that displays information about the ScanWedge Power Tool.
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General Settings
The General Settings section determines how ScanWedge interprets data from the decoder. Additional settings are
included in the Notification (see page 9-3) subsection.

Key Name Description
Default
Value

Available Values

prefix_key ASCII keys to send before the decoded
data

Empty, No
prefix key(s)
sent

Available Values:
8, back
9, tab
12, clear
13, enter
16, shift
18, alt
32, space
33, page up
34, page down
35, end
37, left <
38, up ^
39, right >
40, down
48~57, 0~9
65~90, A~Z

prefix_string Defines the string to be sent prior to the
decoded/received data.

Empty, No
prefix string
sent

For example:
prefix_string = PREFIX

The example listed above would
cause “PREFIX” to be sent prior to
any decoded data.

prefix_id Specifies the symbology identifier sent
prior to the decoded/received data.

0 0 = No symbology identifier is
sent.

1 = The Code ID is sent.
2 = The AIM ID is sent.
3 = The SymModifier is sent.

suffix_key ASCII keys to send after the decoded
data

Empty, No
prefix key(s)
sent

Available Values:
8, back
9, tab
12, clear
13, enter
16, shift
18, alt
32, space
33, page up
34, page down
35, end
37, left <
38, up ^
39, right >
40, down
48~57, 0~9
65~90, A~Z

suffix_string Defines the string to be sent after the de-
coded/received data.

Empty, No
suffix string
sent

For example:
PrefixKeys = SUFFIX

The example listed above would
cause “SUFFIX” to be sent prior to
any decoded data.
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Notification

The Notification section contains parameters for ScanWedge notifications including sound and LED behavior.

Symbology Settings
The Symbology Settings enable and disable bar code symbologies. Symbologies with a checkmark to the left are currently
enabled. Tap the box to enable or disable a symbology. Tap the arrow to the right to access the symbology specific config-
uration parameters.

For more information regarding the individual settings for each of the symbologies, refer to the Honeywell Decode API doc-
umentation in the SDK documentation.

OCR
For comprehensive information about using OCR, refer to the OCR Programming User’s Guide available at
www.honeywellaidc.com.

About
Tap About for information about the ScanWedge Power Tool.

prefix_id Specifies the symbology identifier sent
after the decoded/received data.

0 0 = No symbology identifier is
sent.

1 = The Code ID is sent.
2 = The AIM ID is sent.
3 = The SymModifier is sent.

Key Name Description
Default
Value

Available Values

enable_statusbar-notifica-
tion

Show icon in status bar when scan-
wedge is enabled

true false = Disable; no icon
displayed in taskbar.

true = Enable; icon displayed in
taskbar.

scan_sound Enables and disables audio notifica-
tion for decode/data reception. There
is one sound for success and another
sound for an error.

true false = Disable; no sound on
decoding.

true = Enable; sound on
decoding.

scan_led Enables and disables LED notification
for decode/data reception.

true false = Disable; no LEDs on
decoding.

true = Enable; LEDs on
decoding.

Key Name Description
Default
Value

Available Values

Access Symbology
Parameters

Enable or Disable
Symbology
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ScanTool

Tap Launcher > Power Tools ScanTool . ScanTool initializes and provides several scan-
ning options.

Activity result
Tap Activity result to initiate a scan. The terminal indicates the success or failure of the scan via the LED and the good or
bad scan sound. The scanned data is not stored or used by the application. This option is designed to familiarize an oper-
ator with the good and bad scan indicators.

Show result
Tap Show result to initiate a scan. Upon a successful scan, the bar code data and bar code format are displayed in the
Results panel. The scanned data is not saved or used for any other purposes. After reviewing the results, tap the back key
to return to the ScanTool.

If the scan is unsuccessful, you are returned to the ScanTool screen.

Share by SMS
Tap Share by SMS (Short Message Service, a text messaging service component of phone and mobile devices) to initiate
a scan. Upon a successful scan, an SMS message is opened with the bar code data in the body of the message. To send
the message, enter the recipient(s) and tap Send.

If the scan is unsuccessful, you are returned to the ScanTool screen.

Share by MMS
Tap Share by MMS (Multimedia Message Service, a message format including multimedia content for phones and mobile
devices) to initiate a scan. Upon a successful scan, an MMS message is opened with the bar code data in the body of the
message. To send the message, enter the recipient(s) and tap Send.

If the scan is unsuccessful, you are returned to the ScanTool screen.

Share by email
Tap Share by email to initiate a scan. Upon a successful scan, an email message is opened with the bar code data in the
body of the message. To send the email, enter the recipient(s) and tap Send.

If the scan is unsuccessful, you are returned to the ScanTool screen.

Share by result
Tap Share by result to initiate a scan. The autoshare application is selected by bar code content.

Settings
Tap Settings to enable and disable bar code symbologies. Symbologies with a checkmark to the left are enabled. Tap the
box to enable or disable a symbology. Tap the arrow to the right to access the symbology specific configuration parame-
ters.

Access Symbology
Parameters

Enable or Disable
Symbology
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About
Tap About for information about the ScanTool Power Tool.
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Additional Power Tools
Overview
This chapter describes the following Power Tools:

Power Tool Icon See Page

Apps Config

10-2

BattMon

10-2

Configure Hotkeys

10-3

Counter Viewer

10-4

File Browser

10-4

Logging
10-12

Log View

10-16

NoSIP

10-18

Reboot

10-18

Shell Plus

10-18
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Apps Config
This displays the applications on your device. Click on either or Disable/Enable Apps or Uninstall App Updates. A list of your
applications is displayed. Select those that you want to enable or disable, or those whose automatic updates you want to dis-
continue. To enable or disable these settings in the AppsConfig.xml file, the following syntax is used:

Enable = <App Package Name>:1

Disable = <App Package Name>:0

BattMon
BattMon programs the terminal’s LEDs to monitor the charge status of the battery. The LED is located on the top, front panel of
Dolphin terminals.

To Enable BattMon
After activation, BattMon monitors the battery’s charge status and displays battery information in several formats.

Note: To start BattMon automatically after each reboot, enable the BattMon Program in Autorun Applications on page 6-1.

When the BattMon Power Tool screen is displayed, the status of the battery is shown.

• The battery charge level is indicated in text format at the top of the screen.
• The wallpaper contains a battery icon that is shaded blue in 20% increments to correspond to the level of battery charge.
• The battery icon displays a lightning bolt graphic when external power is attached.

Charge Indicator LED
By default the Charge Indicator LED (located to the right of the speaker at the top front of the terminal) is enabled. The
LED can be disabled. See Enable LED on page 10-3.

• When the battery is at 100%, the LED lights solid green.
• When the battery is charging the LED flashes orange.

To Disable BattMon
Navigate to the Power Tools Main Window (see page 1-1) and tap the BattMon icon again.

Suspend

10-19

SysInfo

10-19

Task Manager

10-22

Power Tool Icon See Page
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Status Bar
When BattMon is enabled, a smaller BattMon icon appears in the notifications area of the status bar at the top of the
screen.

Tap this icon to open the BattMon Power tool.

BattMon Options
Save charging history

Tap the Off/On switch to enable or disable saving the charging history. By default this option is off and
charging history is not saved. When on, the charging history is saved to a log that can be viewed using the All
Charging Records option.

Enable notification

Tap the Off/On switch to enable or disable notifications. By default this option is off, and notifications are not
enabled.

Enable LED

Tap the Off/On switch to enable or disable the Battery Notification LED. By default this option is on, and the
Battery Notification LED is enabled. When enabled the LED is solid green when the battery is 100% charged

About

Tap the More button then tap About on the options menu

The About screen displays information about the BattMon Power Tool.

All Charging Records

Tap the More button then tap All Charging Records on the options menu. The charging history of the device is dis-
played.

Clearing Charging Records

While the Charging Records screen is open, tap the Clear icon and confirm that you want to delete all charging
records. All charging records are erased.

Configure Hotkeys
The HotKeys Power Tool activates the hardware button assignments in the Buttons setting.

To Enable HotKeys
Tap the HotKeys icon once. Press the MENU key and then tap Enable Hotkeys on the options menu. The button assign-
ments in the Buttons setting are active.

Verify the assignment by tapping the button on the keyboard. To see button assignments, see Define Hotkey Applications
on page 10-4.
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Define Hotkey Applications
Select the hardware buttons to launch applications. The keys are listed on the left side of the screen, and the currently
assigned application (if any) is listed to the right of the key name.

1. Tap the Configure Hotkeys icon.

Note: The buttons that appear on this window are the only buttons that can be programmed in the Buttons setting. You
cannot add hardware buttons to this window.

2. To change a button assignment, tap on the name down arrow for that button and select an application in the Select
a application drop down list.

3. To disable an individual hotkey, return to the drop down list and select Empty.

To Disable HotKeys
Tap the HotKeys icon once. Press the MENU key and then tap Disable Hotkeys on the options menu. The button assign-
ments in the Buttons setting are inactive.

About
Press the MENU key then tap About on the options menu

The About screen displays information about the Configure Hotkeys Power Tool.

Counter Viewer
This tool displays counter information for key presses and charging. The following OEM counters are composed of general
events such as boot counts, scan key press counts, keypad events, touch screen events, and timing events.

General Event Counters

General Event Counter
Counter
Index

Description

OEM_HHP_COUNTER_RESERVED 0x00 Reserved

OEM_HHP_COUNTER_COLD_BOOT 0x01 Counts the number of cold-reboots.

OEM_HHP_COUNTER_WARM_BOOT 0x02 Counts the number of warm-reboots.

OEM_HHP_COUNTER_EEPROM_REPAIR 0x03 Counts the number of times the device
repairs radio board EEPROM corruption.

OEM_HHP_COUNTER_DOCK_COUNT 0x05 Counts the number of times the device has
been docked on charge base or connected
to AC power.

OEM_HHP_COUNTER_POWER_KEYPRESS 0x06 Counts the number of times Power key was
pressed.

OEM_HHP_COUNTER_SCAN_KEYPRESS 0x08 Counts the number of times Scan key was
pressed.

OEM_HHP_COUNTER_LONG_TOUCH 0x09 This counter increments if the stylus is not
removed from the touch panel for 1 second.
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Touch Panel Event Counters 
The touch panel is divided into the following 48 sections:  

Each section generates a data event, described below.

A0 A1 A2 A3 A4 A5

B0 B1 B2 B3 B4 B5

C0 C1 C2 C3 C4 C5

D0 D1 D2 D3 D4 D5

E0 E1 E2 E3 E4 E5

F0 F1 F2 F3 F4 F5

G0 G1 G2 G3 G4 G5

H0 H1 H2 H3 H4 H5

Touch Panel Event Counter
Counter
Index

Description

OEM_HHP_COUNTER_ROWA_COLUMN0 0x0A Counts the event generated by section A0
on the touch panel.

OEM_HHP_COUNTER_ROWA_COLUMN1 0x0B Counts the event generated by section A1
on the touch panel.

OEM_HHP_COUNTER_ROWA_COLUMN2 0x0C Counts the event generated by section A2
on the touch panel.

OEM_HHP_COUNTER_ROWA_COLUMN3 0x0D Counts the event generated by section A3
on the touch panel.

OEM_HHP_COUNTER_ROWA_COLUMN4 0x0E Counts the event generated by section A4
on the touch panel.

OEM_HHP_COUNTER_ROWA_COLUMN5 0x0F Counts the event generated by section A5
on the touch panel.

OEM_HHP_COUNTER_ROWB_COLUMN0 0x1A Counts the event generated by section B0
on the touch panel.

OEM_HHP_COUNTER_ROWB_COLUMN1 0x1B Counts the event generated by section B1
on the touch panel.

OEM_HHP_COUNTER_ROWB_COLUMN2 0x1C Counts the event generated by section B2
on the touch panel.

OEM_HHP_COUNTER_ROWB_COLUMN3 0x1D Counts the event generated by section B3
on the touch panel.

OEM_HHP_COUNTER_ROWB_COLUMN4 0x1E Counts the event generated by section B4
on the touch panel.

OEM_HHP_COUNTER_ROWB_COLUMN5 0x1F Counts the event generated by section B5
on the touch panel.

OEM_HHP_COUNTER_ROWC_COLUMN0 0x2A Counts the event generated by section C0
on the touch panel.
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OEM_HHP_COUNTER_ROWC_COLUMN1 0x2B Counts the event generated by section C1
on the touch panel.

OEM_HHP_COUNTER_ROWC_COLUMN2 0x2C Counts the event generated by section C2
on the touch panel.

OEM_HHP_COUNTER_ROWC_COLUMN3 0x2D Counts the event generated by section C3
on the touch panel.

OEM_HHP_COUNTER_ROWC_COLUMN4 0x2E Counts the event generated by section C4
on the touch panel.

OEM_HHP_COUNTER_ROWC_COLUMN5 0x2F Counts the event generated by section C5
on the touch panel.

OEM_HHP_COUNTER_ROWD_COLUMN0 0x3A Counts the event generated by section D0
on the touch panel.

OEM_HHP_COUNTER_ROWD_COLUMN1 0x3B Counts the event generated by section D1
on the touch panel.

OEM_HHP_COUNTER_ROWD_COLUMN2 0x3C Counts the event generated by section D2
on the touch panel.

OEM_HHP_COUNTER_ROWD_COLUMN3 0x3D Counts the event generated by section D3
on the touch panel.

OEM_HHP_COUNTER_ROWD_COLUMN4 0x3E Counts the event generated by section D4
on the touch panel.

OEM_HHP_COUNTER_ROWD_COLUMN5 0x3F Counts the event generated by section D5
on the touch panel.

OEM_HHP_COUNTER_ROWE_COLUMN0 0x4A Counts the event generated by section E0
on the touch panel.

OEM_HHP_COUNTER_ROWE_COLUMN1 0x4B Counts the event generated by section E1
on the touch panel.

OEM_HHP_COUNTER_ROWE_COLUMN2 0x4C Counts the event generated by section E2
on the touch panel.

OEM_HHP_COUNTER_ROWE_COLUMN3 0x4D Counts the event generated by section E3
on the touch panel.

OEM_HHP_COUNTER_ROWE_COLUMN4 0x4E Counts the event generated by section E4
on the touch panel.

OEM_HHP_COUNTER_ROWE_COLUMN5 0x4F Counts the event generated by section E5
on the touch panel.

OEM_HHP_COUNTER_ROWF_COLUMN0 0x5A Counts the event generated by section F0
on the touch panel.

OEM_HHP_COUNTER_ROWF_COLUMN1 0x5B Counts the event generated by section F1
on the touch panel.

OEM_HHP_COUNTER_ROWF_COLUMN2 0x5C Counts the event generated by section F2
on the touch panel.

OEM_HHP_COUNTER_ROWF_COLUMN3 0x5D Counts the event generated by section F3
on the touch panel.

OEM_HHP_COUNTER_ROWF_COLUMN4 0x5E Counts the event generated by section F4
on the touch panel.

OEM_HHP_COUNTER_ROWF_COLUMN5 0x5F Counts the event generated by section F5
on the touch panel.

OEM_HHP_COUNTER_ROWG_COLUMN0 0x6A Counts the event generated by section G0
on the touch panel.

OEM_HHP_COUNTER_ROWG_COLUMN1 0x6B Counts the event generated by section G1
on the touch panel.

Touch Panel Event Counter
Counter
Index

Description
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Keypad Event Counters
Note: Keypad event counters only apply to the Dolphin 7800.

OEM_HHP_COUNTER_ROWG_COLUMN2 0x6C Counts the event generated by section G2
on the touch panel.

OEM_HHP_COUNTER_ROWG_COLUMN3 0x6D Counts the event generated by section G3
on the touch panel.

OEM_HHP_COUNTER_ROWG_COLUMN4 0x6E Counts the event generated by section G4
on the touch panel.

OEM_HHP_COUNTER_ROWG_COLUMN5 0x6F Counts the event generated by section G5
on the touch panel.

OEM_HHP_COUNTER_ROWH_COLUMN0 0x7A Counts the event generated by section H0
on the touch panel.

OEM_HHP_COUNTER_ROWH_COLUMN1 0x7B Counts the event generated by section H1
on the touch panel.

OEM_HHP_COUNTER_ROWH_COLUMN2 0x7C Counts the event generated by section H2
on the touch panel.

OEM_HHP_COUNTER_ROWH_COLUMN3 0x7D Counts the event generated by section H3
on the touch panel.

OEM_HHP_COUNTER_ROWH_COLUMN4 0x7E Counts the event generated by section H4
on the touch panel.

OEM_HHP_COUNTER_ROWH_COLUMN5 0x7F Counts the event generated by section H5
on the touch panel.

Keypad Event Counter
Counter
Index

Description

OEM_HHP_COUNTER_KEY_ESCAPE 0x80 Counts the event generated by pressing
the escape (ESC) key on a keypad.

OEM_HHP_COUNTER_KEY_TAB 0x81 Counts the event generated by pressing
the tab (TAB) key on a keypad.

OEM_HHP_COUNTER_KEY_RIGHT 0x82 Counts the event generated by pressing
the right key on a keypad.

OEM_HHP_COUNTER_KEY_UP 0x83 Counts the event generated by pressing
the up key on a keypad.

OEM_HHP_COUNTER_KEY_LEFT 0x84 Counts the event generated by pressing
the left key on a keypad.

OEM_HHP_COUNTER_KEY_SHIFT 0x85 Counts the event generated by pressing
the shift (SFT) key on a keypad.

OEM_HHP_COUNTER_KEY_HHP_LIGHT 0x86 Counts the event generated by pressing
the light key on a keypad.

OEM_HHP_COUNTER_KEY_6 0x87 Counts the event generated by pressing
the number 6 key on a keypad.

OEM_HHP_COUNTER_KEY_3 0x88 Counts the event generated by pressing
the number 3 key on a keypad.

OEM_HHP_COUNTER_KEY_ENTER 0x89 Counts the event generated by pressing
the enter key on a keypad.

OEM_HHP_COUNTER_KEY_2 0x8A Counts the event generated by pressing
the number 2 key on a keypad.

Touch Panel Event Counter
Counter
Index

Description
10 - 7



OEM_HHP_COUNTER_KEY_DOWN 0x8B Counts the event generated by pressing
the down key on a keypad.

OEM_HHP_COUNTER_KEY_1 0x8C Counts the event generated by pressing
the number 1 key on a keypad.

OEM_HHP_COUNTER_KEY_INSERT 0x8D Counts the event generated by pressing
the insert (INS) key on a keypad.

OEM_HHP_COUNTER_KEY_9 0x8E Counts the event generated by pressing
the number 9 key on a keypad.

OEM_HHP_COUNTER_KEY_8 0x8F Counts the event generated by pressing
the number 8 key on a keypad.

OEM_HHP_COUNTER_KEY_5 0x90 Counts the event generated by pressing
the number 5 key on a keypad.

OEM_HHP_COUNTER_KEY_4 0x91 Counts the event generated by pressing
the number 4 key on a keypad.

OEM_HHP_COUNTER_KEY_7 0x92 Counts the event generated by pressing
the number 7 key on a keypad.

OEM_HHP_COUNTER_KEY_BACK 0x93 Counts the event generated by pressing
the backspace (BKSP) key on a keypad.

OEM_HHP_COUNTER_KEY_SPACE 0x94 Counts the event generated by pressing
the space (SP) key on a keypad.

OEM_HHP_COUNTER_KEY_E 0x95 Counts the event generated by pressing
the Alpha ‘E’ key on a keypad.

OEM_HHP_COUNTER_KEY_COMMA 0x96 Counts the event generated by pressing
the comma (,) key on a keypad.

OEM_HHP_COUNTER_KEY_D 0x97 Counts the event generated by pressing
the alpha ‘D’ key on a keypad.

OEM_HHP_COUNTER_KEY_0 0x98 Counts the event generated by pressing
the number 0 key on a keypad.

OEM_HHP_COUNTER_KEY_C 0x99 Counts the event generated by pressing
the alpha ‘C’ key on a keypad.

OEM_HHP_COUNTER_KEY_PERIOD 0x9A Counts the event generated by pressing
the period (.) key on a keypad.

OEM_HHP_COUNTER_KEY_DELETE 0x9B Counts the event generated by pressing
the delete (DEL) key on a keypad.

OEM_HHP_COUNTER_KEY_J 0x9C Counts the event generated by pressing
the alpha ‘J’ key on a keypad.

OEM_HHP_COUNTER_KEY_I 0x9D Counts the event generated by pressing
the alpha ‘I’ key on a keypad.

OEM_HHP_COUNTER_KEY_H 0x9E Counts the event generated by pressing
the alpha ‘H’ key on a keypad.

OEM_HHP_COUNTER_KEY_B 0x9F Counts the event generated by pressing
the alpha ‘B’ key on a keypad.

OEM_HHP_COUNTER_KEY_G 0xA0 Counts the event generated by pressing
the alpha ‘G’ key on a keypad.

OEM_HHP_COUNTER_KEY_F 0xA1 Counts the event generated by pressing
the alpha ‘F’ key on a keypad.

OEM_HHP_COUNTER_KEY_A 0xA2 Counts the event generated by pressing
the alpha ‘A’ key on a keypad.

OEM_HHP_COUNTER_KEY_N 0xA3 Counts the event generated by pressing
the alpha ‘N’ key on a keypad.

Keypad Event Counter
Counter
Index

Description
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OEM_HHP_COUNTER_KEY_R 0xA4 Counts the event generated by pressing
the alpha ‘R’ key on a keypad.

OEM_HHP_COUNTER_KEY_M 0xA5 Counts the event generated by pressing
the alpha ‘M’ key on a keypad.

OEM_HHP_COUNTER_KEY_L 0xA6 Counts the event generated by pressing
the alpha ‘L’ key on a keypad.

OEM_HHP_COUNTER_KEY_Q 0xA7 Counts the event generated by pressing
the alpha ‘Q’ key on a keypad.

OEM_HHP_COUNTER_KEY_P 0xA8 Counts the event generated by pressing
the alpha ‘P’ key on a keypad.

OEM_HHP_COUNTER_KEY_K 0xA9 Counts the event generated by pressing
the alpha ‘K’ key on a keypad.

OEM_HHP_COUNTER_KEY_Y 0xAA Counts the event generated by pressing
the alpha ‘Y’ key on a keypad.

OEM_HHP_COUNTER_KEY_T 0xAB Counts the event generated by pressing
the alpha ‘T’ key on a keypad.

OEM_HHP_COUNTER_KEY_O 0xAC Counts the event generated by pressing
the alpha ‘O’ key on a keypad.

OEM_HHP_COUNTER_KEY_S 0xAD Counts the event generated by pressing
the alpha ‘S’ key on a keypad.

OEM_HHP_COUNTER_KEY_W 0xAE Counts the event generated by pressing
the alpha ‘W’ key on a keypad.

OEM_HHP_COUNTER_KEY_V 0xAF Counts the event generated by pressing
the alpha ‘V’ key on a keypad.

OEM_HHP_COUNTER_KEY_U 0xB0 Counts the event generated by pressing
the alpha ‘U’ key on a keypad.

OEM_HHP_COUNTER_KEY_Z 0xB1 Counts the event generated by pressing
the alpha ‘Z’ key on a keypad.

OEM_HHP_COUNTER_KEY_X 0xB2 Counts the event generated by pressing
the alpha ‘X’ key on a keypad.

OEM_HHP_COUNTER_KEY_RED_KEY 0xB3 Counts the event generated by pressing
the Red key on a keypad.

OEM_HHP_COUNTER_KEY_BLUE_KEY 0xB4 Counts the event generated by pressing
the blue key on a keypad.

OEM_HHP_COUNTER_KEY_CONTROL 0xB5 Counts the event generated by pressing
the control (CTRL) key on a keypad.

OEM_HHP_COUNTER_KEY_NUM 0xB6 Counts the event generated by pressing
the NUM key on a keypad.

OEM_HHP_COUNTER_KEY_ALT 0xB7 Counts the event generated by pressing
the ALT key on a keypad.

OEM_HHP_COUNTER_KEY_F1 0xB8 Counts the event generated by pressing
the F1 key on a keypad.

OEM_HHP_COUNTER_KEY_F2 0xB9 Counts the event generated by pressing
the F2 key on a keypad.

OEM_HHP_COUNTER_KEY_F3 0xBA Counts the event generated by pressing
the F3 key on a keypad.

OEM_HHP_COUNTER_KEY_F4 0xBB Counts the event generated by pressing
the F4 key on a keypad.

OEM_HHP_COUNTER_KEY_ALPHA 0xBC Counts the event generated by pressing
the ALPHA key on a keypad.

Keypad Event Counter
Counter
Index

Description
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Timer Counters

These counters store the length time for particular events.

OEM_HHP_COUNTER_KEY_SOFT1 0xBD Counts the event generated by pressing
the SOFT1 key on a keypad.

OEM_HHP_COUNTER_KEY_SOFT2 0xBE Counts the event generated by pressing
the SOFT2 key on a keypad.

OEM_HHP_COUNTER_KEY_RIGHT_SIDE 0xBF Counts the event generated by pressing
the right side (programmable/SCAN) key
on a keypad.

OEM_HHP_COUNTER_KEY_LEFT_SIDE 0xC0 Counts the event generated by pressing
the left side (programmable/SCAN) key on
a keypad.

OEM_HHP_COUNTER_KEY_VOLUMEUP 0xC1 Counts the event generated by pressing
the side Volume Up key on a keypad.

OEM_HHP_COUNTER_KEY_VOLUMEDOWN 0xC2 Counts the event generated by pressing
the side Volume Down key on a keypad.

OEM_HHP_COUNTER_KEY_TRIGGER 0xC3 Counts the event generated by pressing
the Trigger SCAN key on a keypad.

OEM_HHP_COUNTER_KEY_SEND 0xC4 Counts the event generated by pressing
the Send key on a keypad.

OEM_HHP_COUNTER_KEY_END 0xC5 Counts the event generated by pressing
the End key on a keypad.

Timer Counter
Counter
Index

Description

OEM_HHP_COUNTER_POWERON_TIME_BT 0xE1 Counts the number of seconds that
BlueTooth was powered on.

OEM_HHP_COUNTER_POWERON_TIME_GSM 0xE2 Counts the number of seconds that the
GSM was powered on.

OEM_HHP_COUNTER_POWERON_TIME_WIFI 0xE3 Counts the number of seconds that WIFI
was powered on.

OEM_HHP_COUNTER_POWERON_TIME_GPS 0xE4 Counts the number of seconds that the
GPS was powered on.

OEM_HHP_COUNTER_POWERON_TIME_DISP_BKLGT 0xE5 Counts the number of seconds that the
display backlight was on.

OEM_HHP_COUNTER_POWERON_TIME_KBD_BKLGT 0xE6 Counts the number of seconds that the
keyboard backlight was on.

OEM_HHP_COUNTER_SUS_TIME 0xE7 Counts the number of seconds that the
device was in suspended state.

OEM_HHP_COUNTER_ON_TIME 0xE8 Counts the number of seconds that the
device was in a running state. This time
excludes the suspend time of the device.

OEM_HHP_COUNTER_SYS_TIME 0xE9 Counts the number of seconds that the
system was on. This time includes
suspend time and run time of the device.

OEM_HHP_COUNTER_BATT_TIME 0xEA Counts the number of seconds that the
device was running on battery.

OEM_HHP_COUNTER_AC_TIME 0xEB Counts the number of seconds that the
device was running on AC power.

Keypad Event Counter
Counter
Index

Description
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Other Counters

SPT Counters

The SPT counters display counter information for bar code scanning activity.

OEM_HHP_COUNTER_SUSRES_CYCLE 0xEC Counts the number of suspend/resume
cycles.

OEM_HHP_POWERON_TIME_Flashlight 0xED Counts the number of seconds that the
flashlight was on.

Other Counter
Counter
Index

Description

OEM_HHP_COUNTER_FREE_FALL 0xEE Counts the free fall times.

OEM_HHP_COUNTER_RESERVED2 0x3FE Verifies that the HHPCeLog works in
HHPStartup program.

Note: The following counters only apply to the Dolphin 70e Black:

OEM_HHP_COUNTER_XLDR_UPDATE 0xEF Counts XLDR update times.

OEM_HHP_COUNTER_EBOOT_UPDATE 0xF0 Counts EBOOT update times.

OEM_HHP_COUNTER_IPL_UPDATE 0xF1 Counts IPL update times.

OEM_HHP_COUNTER_KERNEL_UPDATE 0xF2 Counts KERNEL update times.

OEM_HHP_COUNTER_PSOC_UPDATE 0xF3 Counts PSOC update times.

SPT Counter
Counter
Index

Description

SPT_COUNTER_1D_READS 0x01 Number of 1D symbologies read.

SPT_COUNTER_2D_READS 0x02 Number of 2D symbologies read.

SPT_COUNTER_PDF_READS 0x03 Number of PDF symbols read.

SPT_COUNTER_DECODE_ATTEMPTS 0x04 Number of times the decoder is called.

SPT_COUNTER_NO_DECODES 0x05 Number of times the decoder returned no
decode.

SPT_COUNTER_GET_FRAME_CALLED 0x06 Number of times get single frame is called.

SPT_COUNTER_FRAME_FAIL 0x07 Number of get single frame failures.

SPT_COUNTER_ATTEMPT_CANCELS 0x08 Number of decode attempts canceled.

SPT_COUNTER_ATTEMPT_TIMEOUT 0x09 Number of decode attempts timed out.

SPT_COUNTER_1D_DECODE_TIME 0x0A Total time for 1D decodes.

SPT_COUNTER_2D_DECODE_TIME 0x0B Total time for 2D decodes.

SPT_COUNTER_PDF_DECODE_TIME 0x0C Total time for PDF decodes.

SPT_COUNTER_NO_DECODE_TIME 0x0D Total time for "no decode.”

Timer Counter
Counter
Index

Description
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File Browser
File Browser provides a graphical utility to browse the files stored on the terminal.

Tap a folder name to open that folder.

Tap a filename to open that file. Due to system permissions, some files cannot be opened. Depending on the associated appli-
cation(s), a choice of applications may be available to open the file.

Home
Press the MENU key and tap the Home icon to return to the root folder.

Close
Press the MENU key and tap the Close icon to close File Explorer.

About
Press the MENU key and tap the About icon for information about the File Browser Power Tool.

Logging
Note: This feature is only available on the Dolphin 7800.

There are two general types of log entries:

• System Events - Log entries are made whenever the corresponding event occurs.
• System Status - Log entries are made at a selectable interval.

Logging Settings
Enable Logging
Check the checkbox to enable logging. Uncheck to disable logging. The default is disabled.

When logging is enabled, battery life is reduced as the device must wake up from power management to log the status.

Log File Size
Set the maximum log file size in KB. The default is 10KB. When the log file reaches the limit set here, the beginning
25% of the log file is truncated.

Log Interval
Set the log interval in minutes for the status messages. The default is 1 minute.

Process To Log
Select the processes to be included in the memory usage log entries. By default, logging is enabled for the Scan demo
and Logging Power Tool.

To add a process to the log, enter the path and process name in the Add text box. Enter the process as follows for
either a demo or power tool process:

com.honeywell.demos.<demo name>
com.honeywell.tools.<power tool name>
To remove a process from the log, tap the X to the left of the process name.

Once all desired changes are made, tap Save to save any changes or Cancel to exit without making changes.
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Upload Log
The log file must be uploaded from the Dolphin terminal to be viewed. Use the settings in Upload Log to identify the FTP
server. When all entries are completed, tap the Upload Log button to upload the file to the FTP server.

Server IP
Enter the IP address of the FTP server

Port
Enter the port number to use. Default is 21.

User Name
Enter the user name to log onto the FTP server.

Password
Enter the password for the FTP server.

Remote dir
Enter the directory on the FTP server to store the log file. Default is /.

Remote File
Enter the name of the log file to be stored on the FTP server.

System Events
There are two system events captured in the log:

• Scan Failed Event
• Roaming Event

Scan Failed Event
When a scan fails, an entry is written to the log in the following format with four segments per log entry.

1 2 3 4

02/05/2013, 03:35:16:523, <SCAN_FAILED_EVENT>, <11>, <Trigger state is false>
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1. The date (mm/dd/yyyy) and time (hh:mm:ss:msec) the event happened.

2. The event ID, scan failed event.

3. Failure reason code

4. Detailed explanation corresponding to failure reason code, as detailed below:

Roaming Event
When Wi-Fi roaming occurs, an entry is written to the log in the following format with three segments per log entry.

Failure Code Explanation

1 Invalid image region

2 Error detected in image engine driver

3 Image engine driver reported busy

4 Memory allocation failed

5 Image engine unable to decode symbology

6 No image available

7 Could not communicate with imager

8 Not connected to image engine

9 One of the function parameters was invalid

10 The operation was not supported by the engine

11 Trigger state is false

12 IQ image fail

13 Requested IQ image too large

14 IQ image fail

15 Invalid structure size

16 Could not create async decode thread

17 Asynchronous decode was canceled

18 An exception was detected in the decoder

19 Scanned bar code is not a valid IQ host bar code

20 Error loading EXM file

21 Not a valid configuration file

22 Section missing from EXM file

23 Error processing EXM file section

24 Allow decoder to capture

25 Allow decoder to preview

26 Make decoder to stop previewing

1 2 3

02/05/2013, 03:35:16:523, <ROAMING_EVENT>, <roamingtrigger 6>,
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1. The date (mm/dd/yyyy) and time (hh:mm:ss:msec) the event happened.

2. The event ID, roaming event.

3. Roaming reason code as detailed below:

System Status
The system status messages are written to the log at the specified Log Interval. Three types of System Status messages
are recorded to the log:

• Battery Status
• Memory Status
• CPU Status

Battery Status
The battery status is written to the log in the following format with six segments per log entry.

1. The date (mm/dd/yyyy) and time (hh:mm:ss:msec) the event happened.

2. The event ID, battery info.

3. Current battery charger percent.

4. Battery full charge capacity (in mAh).

5. Battery current charge capacity (in mAh).

6. Battery serial number.

Memory Status
The memory status is written to the log in the following format with seven segments per log entry.

Failure Code Explanation

2 High quality trigger for background scan

3 Normal quality trigger for background scan

4 Low TX rate

5 Low SNR (signal to noise) rate

6 Low quality for roaming

7 TSPEC rejected

8 Maximum TX retries

9 Missed beacon and no ACK on Unicast probe requests

10 Radar detection

11 AP disconnect (de-authenticate or disassociate)

12 Security attack

1 2 3 4 5 6

02/05/2013, 03:35:16:523, <Battery Info>, <100%>, <3864mAh>, <3864mAh>, <JTXB113160046>

1 2 3

02/05/2013, 03:35:16:523, <Total Free Memory>, <50925K>

<com.honeywell.demos.scandemo>, <7447K>, <5788K>, <10848K>

<com.honeywell.tools.logging>, <4401k>, <3120K>, <9412K>

4 5 6 7
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1. The date (mm/dd/yyyy) and time (hh:mm:ss:msec) the event happened.

2. The event ID, total free memory.

3. Total free memory measured in kBytes.

4. Process name to log (determined in settings, one line per process).

5. Total Pss that the process takes (in kBytes).

6. Total private dirty that the process takes (in kBytes).

7. Total shared dirty that the process takes (in kBytes).

CPU Status
The CPU status is written to the log in the following format with three segments per log entry.

1. The date (mm/dd/yyyy) and time (hh:mm:ss:msec) the event happened.

2. The event ID, CPU busy percent.

3. Total CPU busy percentage since last snapshot.

Log Viewer
Log Viewer displays system debug and Logcat (see page 10-17) output information in real time. Additionally, an option is pro-
vided to periodically save the log file. Press the MENU key to access the features below.

Pause / Play

Tap the Pause icon to pause log entries.

Tap the Play to resume log entries after a pause.

Filter

Tap the Filter icon to enter a simple substring or Java-confirming regular expression.

1. Enter the desired filter string in the text box.

2. Check the Apply as regular expression? checkbox if desired.

3. Tap OK to apply the filter or Cancel to exit without saving the filter entries.

4. Tap the Clear button to clear any filter entries and remove the filter.

Clear

Tap the Clear icon to clear the log entries. The log file is cleared and then recreated.

Save

Tap the Save icon to save the log file as a txt file.

The name and location of the saved log file are noted.

1 2 3

02/05/2013, 03:35:16:523, <Cpu Busy Percent>, <23%>
10 - 16



Preferences

Tap the Preferences icon to set Log Viewer preferences.

Grab dmesg
When Grab dmesg is checked, the log displays dmesg messages. These are messages from the kernel.

When Grab dmesg is unchecked, the log displays logcat messages. These are messages from the activity managers
inside the operating system. This is the default setting.

Logcat
The three options below are only available when Grab dmesg is unchecked.

Level
Select the level of logging desired: Verbose (default), Debug, Information, Warning, Fatal.

Format
Log format to use when displaying log entries: Brief (default), Process, Tag, Thread, Time, Long or Raw.

Buffer
Log buffer to display: Main (default), Events, Radio.

Display Settings
Text Size
Select the desired text size for the log file display: Small, Medium (default) or Large.

Background Color
Select the desired background color to use when displaying log entries: White (default), Gray, Black.

Log Behavior
Autoscroll
When checked, automatically scrolls the log output when the log reaches the bottom of the screen. The viewer can
scroll up for earlier entries (default).

When unchecked, the first screen of the log file is displayed. The viewer can scroll down for later entries.

Log Save
Periodic Save
Check the Periodic Save checkbox to enable the log file to be saved at the interval specified below.

When Periodic Save is enabled, an icon is displayed in the notifications area at the top of the screen as shown below.

Frequency
Specify the frequency for the periodic save of the log file: 15 minutes, 30 minutes, 1 hour (default).

Note: The more frequently the log file is saved, the more battery life and storage space is required by this process.

About

Tap the About icon to display information about the Logging Power Tool.
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NoSIP
NoSIP toggles the Soft Input Panel (SIP, or virtual keyboard) between enabled and disabled. By default, the SIP is enabled.
When disabled, the SIP does not automatically pop up over application windows.

To Enable NoSIP
Tap the NoSIP icon. Select OK to disable the SIP. The SIP does not pop up on application screens.

To Disable NoSIP
Navigate to the Power Tools Main Window (see page 1-1) and tap the NoSIP icon again. Select OK to enable the SIP.

Reboot
Reboot performs a reboot from the touch screen. All Dolphin terminals reboot with keyboard commands. Reboot offers you the
option of using the touch screen instead.

Rebooting the Dolphin terminal
Tap the Reboot icon. The Reboot confirmation appears.

To perform a reboot, tap the Reboot button.

The Dolphin terminal begins booting immediately.

Shell Plus
Tap the Shell Plus icon to open a Linux Shell on the device into which the user can enter commands. Multiple shells are sup-
ported.

New Window
Opens a new shell window.

Close Window
Closes the current shell window.

Windows
Lists the currently open shell windows.

Toggle Soft Keyboard
Toggles the soft keyboard on or off in the current window.

Preferences
Status Bar
Shows or hides the status bar. The default is hide.

Font Size
Sets the character size in points. The default is 10 pt.
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Text Color
Chooses the text color. The default is white text on a blue background.

Back Button Behavior
Chooses what happens when the Back button is pressed. The default is to close the activity leaving sessions running.

Control Key
Chooses the control key. The default is the Volume Up key.

Close window on exit
Selects whether a window should close when its shell exits. The default is to close the window.

More
Reset term
Tap the More icon then tap the Reset term icon.

The current session screen is cleared.

About
Tap the More icon then tap the About icon.

The About screen displays information about the Shell Plus Power Tool.

Suspend
Suspend puts the terminal in Suspend mode. All Dolphin terminals have keyboard commands that put the terminal in Suspend
mode. Suspend offers you the option of using the touch screen instead.

To Suspend the Dolphin Terminal
Tap the Suspend icon once. The terminal goes into Suspend mode.

To wake the Dolphin Terminal from Suspend Mode, press the SCAN or Power key.

SysInfo
SysInfo provides a read-out of important system information including firmware versions, application versions, system parame-
ters, as well as network and radio information.

To See System Information
Tap the SysInfo icon once. SysInfo queries the system, compiles the data and displays it on the SysInfo screen.

You cannot edit information in SysInfo. This information is gathered from the Dolphin terminal and changes only when the
terminal’s configuration has changed.

To Save the System Information to a Text File
Press the MENU key then tap the Save on the options menu. A file named SYSINFO.txt is generated and saved to the
SD card in the \Honeywell folder.

To open the file, use the File Browser Power Tool and navigate to \sdcard\honeywell.  The SYSINFO.txt file
appears in the list.
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Viewing Options
If you tap on the SYSINFO.txt file on the device, you are given a selection of applications to open the file. Select the
desired application. You cannot change system information by editing the text.

To Upload SYSINFO.txt to a Workstation
You can upload the SYSINFO.txt file to a workstation after connecting the terminal to a PC and turning on USB storage.

1. On the workstation, open Windows Explorer.

2. Navigate to the \Honeywell folder on drive corresponding to the terminal’s SD card.

3. Copy and paste this file to a folder on your workstation.

Sample SysInfo File

Field Sample Data

SYSTEM DATE/TIME

Date/Time Apr 24, 2013 2.14.27 PM

SYSTEM INFO

PRODUCT d7800

BRAND Honeywell

MODEL D7800AD

TYPE user

CPU_ABI armeabi-v7a

INCREMENTAL 38.00.20130305

SERVICE_PACK 38.00.SP8.20130305

RELEASE 2.3.4

Memory Total 250023936

Memory Free 4460544

Memory Cached 89563136

Memory Buffers 147456

IPSM Total Space 0

IPSM Available Space 0

SD Card Total Space 4002889728

SD Card Available Space 3974729728

Internal Storage Total Space 211386368

Internal Storage Available Space 171917312

POWER TOOLS AND DEMOS INFO

NOSIP 1.0

REBOOT 2.19

BACKUP 2.19

FILEBROWSER 2.19

SCANWEDGE 2.19

TERM 2.19
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TASKMANAGER 2.19

LOGVIEW 2.19

AUTORUN 2.19

PING 2.19

SYSINFO 2.19

IPCONFIG 2.19

SUSPEND 2.19

DEVICECONFIG 2.19

EZMENU 2.19

EZPROVIDER 2.19

HOTKEYS 2.19

XMLEDITOR 2.19

BATTMON 2.19

EZCONFIG 2.19

ROUTE 2.19

SCANTOOL 2.19

IMAGINGDEMO 2.19

BTRSPRINT 2.19

GPSDEMO 2.19

CAMERADEMO 2.19

SCANDEMO 2.19

SIGNATUREDEMO 2.19

IQIMAGE 2.19

HSM SYSTEM INFO

XLOADER_VERSION 38.00.20120523

UBOOT_VERSION 38.00.20120619

RECOVERY_VERSION 38.00.20120523

OSIMAGE_VERSION 38.00.20130305

MCU_VERSION 38.00 May 23 2012

MFG_DATE 20110521

MFG_MODEL_NUM 7800

MFG_SERIAL_NUM 11161DE038

MFG_PART_NUM 7800LWQ-GC123XE

ODM_TRACKING_NUM 0C220019

CONFIG_NUM 7800LWQ-GC123XE

CUSTOM_SERIAL_NUM

FLASH_SIZE 1047040

KEYBOARD_TYPE 30-key

HARDWARE_REV 2

FEATURE_SET 681265592

Field Sample Data
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Task Manager
The Task Manager screen displays all running applications.

Tap the Kill icon to the right of the application name to close that application.

Tap the Kill All icon to kill all running applications.

Tap the Refresh icon to refresh the application listing.

About

Press the MENU key then Tap the About icon.

The About screen displays information about the Task Manager Power Tool.

RESET_REASON 0

WAKE_SOURCE 2064

MFG_DATA_VALID 0

GSM_BASEBAND_VERSION REVISION 01.002

IMAGER & DECODER INFO

Engine ID 12

Engine Type N5603SR-BR (80050d01)

Engine Serial Number 11224B0996

PSOC Major Revision 6

PSOC Minor Revision 6

APIRevision:
Decoder. SO Revision

2.20

ControlLogicRevision:
Control Logic Version

1.49.1.11a

DecoderRevision:
Integrated Decoder Version

2012.2.591

SecondaryDecoderRevision:
RapidScan -MC- Version

1.16.1.4

DecThreadsRevison not available

ScanDriverRevison Unsupported

Image Width 832

Image Height 640

Preview Image Width 208

Preview Image Height 160

Field Sample Data
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Customer Support
Technical Assistance
If you need assistance installing or troubleshooting your device, please contact us by using one of the methods below:

Knowledge Base: www.hsmknowledgebase.com

Our Knowledge Base provides thousands of immediate solutions. If the Knowledge Base cannot help, our Technical Support
Portal (see below) provides an easy way to report your problem or ask your question.

Technical Support Portal: www.hsmsupportportal.com

The Technical Support Portal not only allows you to report your problem, but it also provides immediate solutions to your techni-
cal issues by searching our Knowledge Base. With the Portal, you can submit and track your questions online and send and
receive attachments.

Web form: www.hsmcontactsupport.com

You can contact our technical support team directly by filling out our online support form. Enter your contact details and the
description of the question/problem.

Telephone: www.honeywellaidc.com/locations

For our latest contact information, please check our website at the link above.
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